Get it on Google Play

z-index amb flash i vídeos

18-10-2006
 

L’altre dia hem vaig trobar amb un problema amb una pàgina web que contenia animacions flash i vídeos. La qüestió es que d’entrada el flash i els vídeos no respecten el z-index dels contenidors i sempre surten en primer pla. Per arreglar-ho s’ha d’afegir el que està amb negreta:

Per a animacions flash:

<object id=”mediaPlayer” classid=”…” width=”320″ height=”290″ align=”” vspace=”5″ hspace=”5″ codebase=”http://activex.microsoft.com /activex/controls /mplayer/en/nsmp2inf.cab #Version=5,1,52,701″ STANDBY=”Loading Microsoft Windows Media Player components…”>
<param name=”showControls” value=”true”/>
<param name=”type” value=”application/x-mplayer2″/>
<param name=”autoStart” value=”true”/>
<param name=”fileName” value=”video.wmv”/>
<param name=”animationAtStart” value=”true”/>
<param name=”wmode” value=”opaque”/>
<param name=”showStatusBar” value=”false”/>
<param name=”clickToPlay” value=”false”/>
<param name=”transparentAtStart” value=”true”/>
<param name=”WindowlessVideo” value=”1″/>
<embed width=”320″ height=”290″ showcontrols=”true” showDisplay=”false” src=”video.wmv” type=”application/x-mplayer2″ align=”” pluginspage=”http://www.microsoft.com /Windows/ Downloads/Contents/ MediaPlayer/” showstatusbar=”false” showdisplay=”false” autostart=”true” hspace=”5″ vspace=”5″ wmode=”opaque”></embed>
</object>

Per a vídeos:

<object id=”fl” classid=”…” codebase=”https://download.macromedia.com /pub/shockwave/ cabs/flash/ swflash.cab#version=6,0,29,0″ width=”350″ height=”240″>
<param name=”movie” value=”PEO959561A_R.swf”/>
<param name=”quality” value=”high”/>
<param name=”menu” value=”false”/>
<param name=”wmode” value=”opaque”/>
<embed src=”PEO959561A_R.swf” width=”350″ height=”240″ quality=”high” pluginspage=”https://www.macromedia.com/go/getflashplayer” type=”application/x-shockwave-flash” menu=”false” wmode=”opaque”>
</embed>
</object>

El que esta en negreta es el codi que evita els solapaments.

Leave a Reply

© Albert Coronado Calzada